ユーザ用ツール

サイト用ツール


aws:directconnect:2vpc

AWS Direct Connect(DX)で、複数のVPCと接続する構成例

複数のVPCと接続するイメージ図

複数のVPCと接続するイメージ図


Cisco設定例

Active L3

ip vrf VRF1
  rd xxxxx:1

ip vrf VRF2
  rd xxxxx:2

! ### track ###
track 1 interface GigabitEthernet1/0/1 line-protocol

track 2 ip router x.x.x.x. 255.255.255.252 reachability
  ip vrf VRF1

track 3 list boolean and
  object 1
  object 2

! ### track ###
track 4 interface GigabitEthernet1/0/1 line-protocol

track 5 ip router x.x.x.x. 255.255.255.252 reachability
  ip vrf VRF1

track 6 list boolean and
  object 4
  object 5




! ### LAN側 interface Vlan ####
interface Vlan10
  ip vrf forwading VRF1
  ip address x.x.x.x 255.255.255.0
  standby 100 ip x.x.x.1
  standby 100 priority 105
  standby 100 track 3 decrement 20

interface Vlan10
  ip vrf forwading VRF2
  ip address x.x.x.x 255.255.255.0
  standby 100 ip x.x.x.1
  standby 100 priority 105
  standby 100 track 6 decrement 20


! ### DX側 interface Vlan ###
interface VlanXX
  ip vrf forwading VRF1
  ip address x.x.x.x 255.255.255.0

interface VlanXX
  ip vrf forwading VRF2
  ip address x.x.x.x 255.255.255.0


! ### BGP ###
router bgp xxxx

  address-family ipv4 vrf VRF1
    networkx.x.x.x.x mask 255.255.255.0
    neighbor x.x.x.x remote-as xxxx
    neighbor x.x.x.x active

  address-family ipv4 vrf VRF2
    networkx.x.x.x.x mask 255.255.255.0
    neighbor x.x.x.x remote-as xxxx
    neighbor x.x.x.x active


aws/directconnect/2vpc.txt · 最終更新: 2019/09/09 11:06 by kurihara

ページ用ツール